Eteria IRC Client

Sorry, but you need a Java 1.1.x enabled browser to use EIRC.

 
Copyright © Sveskebanden 2001 - site made by Magnify & Nereus

chart.dk